K&K

スポンサーサイト

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。
  1. --/--/--(--) --:--:--|
  2. スポンサー広告

中間証明書

InternetExplorer → 閲覧可能
Firefox3.0以上 → 証明書のエラー

ググッた結果はそのサイトが中間証明書を入れていないとの事。
IEが見れるのは、証明書の情報を頼りに上位の証明書を取得しに行く機能がある為らしく
厳密にはFireFoxの動作が正しいらしい。

サーバはapache2.0.63
中間CAは SSLCertificateChainFileに書いてる。

http://www.hozen.org/ml/1/thread/2202
な記事もあったがソースを見たところ修正されてる。

一体どこだ・・・・




IEを見ると証明書の有効期限が2005年~2015年
フツーのサイトは2007年だ

とりあえずIEからその証明書をエクスポートして無理矢理サーバに当ててみた。




キタ━━━━(゚∀゚)━━━━!!!!


https://www.verisign.co.jp/repository/intermediate.html

↑ベリサイン社にも問い合わせたら原因はコレ。

該当サイトは顧客が証明書を取得しており、サーバへの設定依頼のみされたので
他サイトと同じ中間証明書を当ててしまっていた。
マネージドPKIで申請し、2048bitで取得すると違う中間証明書になるらしい。

コレで2日ハマりました・・・
スポンサーサイト
  1. 2009/01/29(木) 23:37:39|
  2. IT関連
  3. | トラックバック:0
  4. | コメント:0
<<vsftpのバグ | ホーム |

コメント

コメントの投稿

管理者にだけ表示を許可する

トラックバック

トラックバックURLはこちら
http://monpti.blog87.fc2.com/tb.php/1-33aecb42
この記事にトラックバックする(FC2ブログユーザー)
上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。